Support Center Contact Forms Not Loading
Incident Report for Desk
Resolved
Our developers have identified and resolved the issue. Thank you for your patience!
Posted 19 days ago. Aug 06, 2019 - 15:19 PDT
Update
Our developers are still investigating the issue. They believe they have identified the possible cause of the issue and are doing their due diligence to hopefully resolve this really soon.
Posted 19 days ago. Aug 06, 2019 - 14:21 PDT
Update
Our developers are still investigating the issue with a high priority. Thank you for your patience!
Posted 19 days ago. Aug 06, 2019 - 13:18 PDT
Update
We are continuing to investigate this issue.
Posted 19 days ago. Aug 06, 2019 - 12:48 PDT
Investigating
We are looking into an issue where the email contact page on Desk Support Centers isn't loading correctly.
Posted 20 days ago. Aug 06, 2019 - 12:13 PDT
This incident affected: Support Centers (Contact Forms).