Desk.com is now retired
Incident Report for Desk
Update
Desk.com is now retired. Thank you for being a Desk.com customer.
Posted Mar 13, 2020 - 09:10 PDT
Investigating
Please be sure that your teams are aware that Desk.com will no longer be available as of 9AM PT. (approximately 45 minutes from now). At this time, we suggest that your teams wrap up any work they are doing and prepare to no longer have access to Desk.com. Thank you!
Posted Mar 13, 2020 - 08:19 PDT