Support Center Contact Forms not Loading
Incident Report for Desk
Resolved
We have fixed the issue with Support Center contact page forms not loading. Please email support@desk.com if you see any ongoing issues.
Posted 20 days ago. Aug 05, 2019 - 23:30 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 20 days ago. Aug 05, 2019 - 23:26 PDT
Update
We are continuing to work on a fix for this issue.
Posted 20 days ago. Aug 05, 2019 - 22:56 PDT
Identified
We have identified the issue and are working to put a fix in place. Thanks for your patience so far.
Posted 20 days ago. Aug 05, 2019 - 22:21 PDT
Investigating
We are looking into an issue where the email contact page on Desk Support Centers isn't loading correctly.
Posted 20 days ago. Aug 05, 2019 - 21:58 PDT
This incident affected: Support Centers (Contact Forms).